Some orders cannot be fulfilled when shipped from third party sellers
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted Jul 03, 2023 - 16:24 PDT
Investigating
We are investigating an issue with orders containing items from third party sellers. At this time, it appears Amazon has a bug that prevents those items from being delivered to the shopper address. We are awaiting a fix from Amazon. In the meantime, please cancel those orders until a resolution is found. Sorry for the inconvenience.
Posted Oct 31, 2022 - 15:44 PDT
This incident affected: Earning.