Japanese order creation currently broken

Incident Report for Purse IO

Resolved

This incident has been resolved.
Posted Jul 21, 2022 - 21:01 PDT

Investigating

This issue only pertains to orders created on amazon.jp
Posted Jul 21, 2022 - 17:01 PDT
This incident affected: Shopping.