Bitcoin withdrawals intermittently failing

Incident Report for Purse IO

Resolved

This incident has been resolved.
Posted Aug 07, 2023 - 11:33 PDT

Update

We have identified the issue and have attempted to resend all failed withdrawals.
Posted Aug 07, 2023 - 11:27 PDT

Investigating

We are noticing some failed withdrawals on the Bitcoin Network. if your withdrawal fails, we will retry sending
Posted Aug 07, 2023 - 11:07 PDT
This incident affected: BTC Withdraws.